re = /^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$/m
str = ' First name
First name
First name
8First name
First name8
First name last name
Some.name with spaces'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end