package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$`)
var str = ` First name
First name
First name
8First name
First name8
First name last name
Some.name with spaces`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}