using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$";
string input = @" First name
First name
First name
8First name
First name8
First name last name
Some.name with spaces";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}