// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z](?:[a-zA-Z\.\s][^\n]*)[a-zA-Z]$").unwrap();
let string = " First name
First name
First name
8First name
First name8
First name last name
Some.name with spaces";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}