# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[\t\s]*)(forgot: "to",)(?!\n[\t\s]*insert: "something",)/\1\2\n\1insert: "something",/m;t' <<< " oops: {
forgot: \"to\",
in: \"here\"
},"