re = /(^[\t\s]*)(forgot: "to",)(?!\n[\t\s]*insert: "something",)/m
str = ' oops: {
forgot: "to",
in: "here"
},'
subst = '\\1\\2\\n\\1insert: "something",'
result = str.sub(re, subst)
# Print the result of the substitution
puts result