#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[\t\s]*)(forgot: "to",)(?!\n[\t\s]*insert: "something",)"
Local $sString = " oops: {" & @CRLF & _
" forgot: "to"," & @CRLF & _
" in: "here"" & @CRLF & _
" },"
Local $sSubst = "\1\2\n\1insert: "something","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)