import re
regex = re.compile(r"(^[\t\s]*)(forgot: \"to\",)(?!\n[\t\s]*insert: \"something\",)", flags=re.MULTILINE)
test_str = (" oops: {\n"
" forgot: \"to\",\n"
" in: \"here\"\n"
" },")
subst = "\\1\\2\\n\\1insert: \"something\","
result = regex.sub(subst, test_str, count=1)
if result:
print(result)