use strict;
my $str = ' oops: {
forgot: "to",
in: "here"
},';
my $regex = qr/(^[\t\s]*)(forgot: "to",)(?!\n[\t\s]*insert: "something",)/mp;
my $subst = '\\1\\2\\n\\1insert: "something",';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";