$re = '/(^[\t\s]*)(forgot: "to",)(?!\n[\t\s]*insert: "something",)/m';
$str = ' oops: {
forgot: "to",
in: "here"
},';
$subst = "\1\2\n\1insert: \"something\",";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;