#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$"
Local $sString = "http://www.google.com" & @CRLF & _
"http://www.google.be" & @CRLF & _
"http://www.google.drvff" & @CRLF & _
"http://www.com" & @CRLF & _
"http://www.com.dd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")