using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$";
string input = @"http://www.google.com
http://www.google.be
http://www.google.drvff
http://www.com
http://www.com.dd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}