const regex = /^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http:\\\/\\\/www.+[a-zA-Z0-9]\\.[a-z]{2,3}$', 'gim')
const str = `http://www.google.com
http://www.google.be
http://www.google.drvff
http://www.com
http://www.com.dd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}