package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$`)
var str = `http://www.google.com
http://www.google.be
http://www.google.drvff
http://www.com
http://www.com.dd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}