$re = '/^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$/im';
$str = 'http://www.google.com
http://www.google.be
http://www.google.drvff
http://www.com
http://www.com.dd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);