re = /^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$/im
str = 'http://www.google.com
http://www.google.be
http://www.google.drvff
http://www.com
http://www.com.dd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end