// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^http:\/\/www.+[a-zA-Z0-9]\.[a-z]{2,3}$").unwrap();
let string = "http://www.google.com
http://www.google.be
http://www.google.drvff
http://www.com
http://www.com.dd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}