using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.)\,";
string substitution = @"""\0""";
string input = @"i tags=$((1 << (i -1)))
map normal $i set-focused $tags";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}