const regex = new RegExp('\\((.)\\,', 'gm')
const str = `i tags=\$((1 << (i -1)))
map normal \$i set-focused \$tags`;
const subst = `"\0"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);