use strict;
my $str = 'i tags=$((1 << (i -1)))
map normal $i set-focused $tags';
my $regex = qr/\((.)\,/mp;
my $subst = '"\\0"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";