// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((.)\,").unwrap();
let string = "i tags=$((1 << (i -1)))
map normal $i set-focused $tags";
let substitution = "\"\\0\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}