import Foundation
let pattern = #"\((.)\,"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
i tags=$((1 << (i -1)))
map normal $i set-focused $tags
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\0""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)