re = /\((.)\,/m
str = 'i tags=$((1 << (i -1)))
map normal $i set-focused $tags'
subst = '"\\0"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result