#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<td.*?class="wertCaption".*?>(?<value>[^<]*)"
Local $sString = "<td class="balkenL"><div style="width:16px;background-color:#D30029;"> </div></td>" & @CRLF & _
"<td class="wertL"><span>107,35</span></td>" & @CRLF & _
"<td class="wertCaption">Fehlpässe</td>" & @CRLF & _
"<td class="wertR">104,82</td>" & @CRLF & _
"<td class="balkenR"><div style="width:16px;background-color:#C2BFBF;"> </div></td> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")