// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<td.*?class="wertCaption".*?>(?<value>[^<]*)"#).unwrap();
let string = "<td class=\"balkenL\"><div style=\"width:16px;background-color:#D30029;\"> </div></td>
<td class=\"wertL\"><span>107,35</span></td>
<td class=\"wertCaption\">Fehlpässe</td>
<td class=\"wertR\">104,82</td>
<td class=\"balkenR\"><div style=\"width:16px;background-color:#C2BFBF;\"> </div></td> ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}