import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td.*?class=\"wertCaption\".*?>(?<value>[^<]*)";
final String string = "<td class=\"balkenL\"><div style=\"width:16px;background-color:#D30029;\"> </div></td>\n"
+ "<td class=\"wertL\"><span>107,35</span></td>\n"
+ "<td class=\"wertCaption\">Fehlpässe</td>\n"
+ "<td class=\"wertR\">104,82</td>\n"
+ "<td class=\"balkenR\"><div style=\"width:16px;background-color:#C2BFBF;\"> </div></td> ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}