# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td.*?class=\"wertCaption\".*?>(?<value>[^<]*)"
test_str = ("<td class=\"balkenL\"><div style=\"width:16px;background-color:#D30029;\"> </div></td>\n"
"<td class=\"wertL\"><span>107,35</span></td>\n"
"<td class=\"wertCaption\">Fehlpässe</td>\n"
"<td class=\"wertR\">104,82</td>\n"
"<td class=\"balkenR\"><div style=\"width:16px;background-color:#C2BFBF;\"> </div></td> ")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.