import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "nan|(?:2019|202[0-5])";
final String string = "21 JUNE 23.59\n"
+ "18TH JUN 23:59\n"
+ "01TH JULY (23.59 HRS)\n"
+ "28th June 2023\n"
+ "5TH MAY 2023\n"
+ "JUNE 27, 2023";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}