use strict;
my $str = '21 JUNE 23.59
18TH JUN 23:59
01TH JULY (23.59 HRS)
28th June 2023
5TH MAY 2023
JUNE 27, 2023';
my $regex = qr/nan|(?:2019|202[0-5])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}