import re
regex = re.compile(r"nan|(?:2019|202[0-5])", flags=re.MULTILINE)
test_str = ("21 JUNE 23.59\n"
"18TH JUN 23:59\n"
"01TH JULY (23.59 HRS)\n"
"28th June 2023\n"
"5TH MAY 2023\n"
"JUNE 27, 2023")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")