const regex = new RegExp('nan|(?:2019|202[0-5])', 'gm')
const str = `21 JUNE 23.59
18TH JUN 23:59
01TH JULY (23.59 HRS)
28th June 2023
5TH MAY 2023
JUNE 27, 2023`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}