$re = '/nan|(?:2019|202[0-5])/m';
$str = '21 JUNE 23.59
18TH JUN 23:59
01TH JULY (23.59 HRS)
28th June 2023
5TH MAY 2023
JUNE 27, 2023';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);