# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(\w+\[[^]]+\]:'[^']+')//gi;t' <<< "id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 текст2'"