$re = '/\s(\w+\[[^]]+\]:\'[^\']+\')/i';
$str = 'id[varchar]:\'текст1 текст2\' col_2[varchar]:\'текст1 текст2\' col_3[varchar]:\'текст1 текст2\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;