package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s(\w+\[[^]]+\]:'[^']+')`)
var str = `id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 текст2'`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}