const regex = /\s(\w+\[[^]]+\]:'[^']+')/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(\\w+\\[[^]]+\\]:\'[^\']+\')', 'gi')
const str = `id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 текст2'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);