using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(\w+\[[^]]+\]:'[^']+')";
string substitution = @"";
string input = @"id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 текст2'";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}