import re
regex = re.compile(r"\s(\w+\[[^]]+\]:'[^']+')", flags=re.IGNORECASE)
test_str = "id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 текст2'"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)