re = /\s(\w+\[[^]]+\]:'[^']+')/i
str = 'id[varchar]:\'текст1 текст2\' col_2[varchar]:\'текст1 текст2\' col_3[varchar]:\'текст1 текст2\''
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result