import Foundation
let pattern = #"\s(\w+\[[^]]+\]:'[^']+')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"id[varchar]:'текст1 текст2' col_2[varchar]:'текст1 текст2' col_3[varchar]:'текст1 текст2'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)