using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$";
string input = @"1.2.33..3
123.345.2.321
12
123.32.32
.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}