$re = '/^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$/m';
$str = '1.2.33..3
123.345.2.321
12
123.32.32
.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);