// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$").unwrap();
let string = "1.2.33..3
123.345.2.321
12
123.32.32
.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}