import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{1,3}(?:\\.\\d{1,3}){0,2}(?:\\.\\d{0,3})?)?$";
final String string = "1.2.33..3\n"
+ "123.345.2.321\n"
+ "12\n"
+ "123.32.32\n"
+ ".\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}