const regex = /^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,3}(?:\\.\\d{1,3}){0,2}(?:\\.\\d{0,3})?)?$', 'gm')
const str = `1.2.33..3
123.345.2.321
12
123.32.32
.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}