package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$`)
var str = `1.2.33..3
123.345.2.321
12
123.32.32
.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}