import re
regex = re.compile(r"^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$", flags=re.MULTILINE)
test_str = ("1.2.33..3\n"
"123.345.2.321\n"
"12\n"
"123.32.32\n"
".\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")