re = /^(?:\d{1,3}(?:\.\d{1,3}){0,2}(?:\.\d{0,3})?)?$/m
str = '1.2.33..3
123.345.2.321
12
123.32.32
.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end