import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\w.*>)(&)(?=.*<\\/)";
final String string = "Walter & Cooper";
final String subst = "result context-3=\"131180\" context-ui-effect=\"key-change\" control-mode=\"bns\" /";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}