import Foundation
let pattern = #"(?!\w.*>)(&)(?=.*<\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Walter & Cooper"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"result context-3="131180" context-ui-effect="key-change" control-mode="bns" /"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}